Running a Java ME8 MIDlet on a STM32f4Discovery board... I tried it...

Hello everyone,

after I read an older Java Magazin Article about Oracle targeting the IoT world with it’s JavaME 8 platform I tried to install and run it on the STM32f4 discovery board. After downloading about 1GB of tools and installing it on a Windows7  machine, I finally flashed the discovery board with the VM.

Installed some USB drivers and tried to connect to upload a MIDlet flashing an LED similar to the Arduino Blink demo. For an old JavaME programmer (ColorKVM, kAWT, ME4SE) as I started to work on mobile phones more than a decade ago, the sample looks very familiar to me:

Well, I compiled and tried to run this simple MIDlet as described in the documentation Netbeans tries to connect to the board, but stops the build after a while returning an error that it cannot connect. When I start the CLI, and ask the ams for a list of install MIDlets, I’m getting an error, that the device is not connected.

Well it is early access, but I was expecting that I even could install a small MIDlet to get an LED blink.

Has anyone yet some experience which is more successful than mine?

The Early Access version of the software for the STM32f4 Discovery board was released in September 2013, which is rather old now. Hope that Oracle will release another version of the JavaME8 for the STM32f4 Discovery board soon.

Hope to write about better results the next time,